1
Vote

SMTP Server

description

Hello

I have not actually attempted to use this module for quite some time, but I know that it was working fine some time ago!

I'm running DNN 7.03.03, have updated to Feedback v 6.4.3, and started a new site as well. Both sites give me

"There is a problem with the configuration of your SMTP Server. Mail was not sent"

when I attempt to send feedback, despite the fact that the "Test SMTP Settings" in Host Settings works fine and I receive the "DNN Corp SMTP Configuration Test" message with no problem.

Feedback messages DO get posted and are awaiting moderation, so it's just the message-sending part which is failing.

Where should I look to fix this? There are no messages in the DNN event log.

Thanks for any suggestions
Ade

comments

lewisar wrote Nov 5, 2014 at 2:08 PM

OK, I just stopped and started the sites, and now I'm seeing general exceptions in the event log:

The SMTP server requires a secure connection or the client was not authenticated. The server response was: SMTP authentication is required.

Do I need to adjust a setting somewhere? The Test SMTP Settings" option still works fine!

Also, on a separate topic entirely (for which I apologise in advance), is there any way to stop the captcha generator using "o" or "0"? It's impossible to tell which is which, and then you lose confidence that the case-sensitivity isn't a problem.

Ade

lewisar wrote Nov 6, 2014 at 10:50 AM

OK, if I uncheck the "send copy" option, and make sure the "send to" address is in the same domain as the hosted site, it works. But any "external" email address fails with the original error.

I have no problems using the domain email account with Outlook, phone etc?

Any ideas anyone?

Ade

RogerSelwyn wrote Nov 6, 2014 at 11:19 AM

It might be worth having a scan of the documentation here - https://dnnfeedback.codeplex.com/wikipage?title=Descripition%20of%20the%20Feedback%20Module%20Settings&referringTitle=Documentation.

What you have discovered is that many ISPs only allow you to use their SMTP server to send emails from addresses in the same domain as the hosted domain. i.e. you can just send from any random address. The module settings then allow for flexibility.

lewisar wrote Nov 10, 2014 at 6:15 PM

Hi Roger

Thanks for your response. I'm afraid I thought I sent a response to your message a couple of days ago, but I evidently forgot to click the "submit" button!

What I think I have discovered is not that I have to use the ISP's SMTP server to send emails, as I was already using that, and it was the way it had always been configured. It seems that it is only allowing me to send TO target addresses on the same host domain?

The DNN SMTP Basic Authentication has always been set to use a domain email account, and I'm OK with that. If I have just one address in the Feedback "Send To" box, and it's in the local host domain, it all works fine. But if I either use a non-domain target in that box, or add a second address which is a non-domain target, or click the "send a copy" box and use a non-domain address, then I get the SMTP server failure in the event log.

I don't think this is a Feedback module problem, as more worryingly, since I could cope with the Feedback module only using a local domain address, the NBStore module is now failing to send order confirmation messages with the same SMTP server message in the log. Since my webmail still works, I can only think that something has changed in the latest release of DNN, either something no longer works, or something requires an extra config tweak which I haven't noticed maybe??

Any ideas anyone? Is everyone else use DNN 7.3.3 without any problems?

Ade

lewisar wrote Nov 12, 2014 at 12:52 PM

One more piece of information, as I'm getting increasingly concerned about this...

I just noticed that there is an "SMTP Server Settings" under Admin/Site Settings/Advanced Settings, as well as under Host/Host Settings/Advanced Settings, and they behave differently.

Under Admin, there is a pair of radio buttons with options "Host" or "Portal". If I select "Host" there are no other options and the "Test SMTP Settings" button fails. If I select "Portal" and set it up exactly the same way as the Host/Host Settings version, then click the "Test SMTP Settings" button, it also fails. If I click the "Test SMTP Settings" button under the "Host" options however, it works.

But I can still not send email to any domain other than the Host domain, from any DNN option that I've tried?

Ade

lewisar wrote Nov 13, 2014 at 2:50 PM

AARRGGHH! I just noticed the "update" flag on my website when logged in as Host, went to look at the "Security Update" notice and found the fix was for:

"Failure to validate user messaging permissions"!

(flagged MEDIUM not CRITICAL???)

So I have now upgraded from 7.3.3 to 7.3.4 and the problem is fixed!!

Would be nice if all you "dnn" guys spoke to each other!

Thanks for your response anyway

Ade

RogerSelwyn wrote Nov 13, 2014 at 4:47 PM

Unfortunately as a 'dnn' guy I do this in my spare time (this is true of many of the people who support addon modules), of which I have pretty much had none in the last 6 months which is why I am providing very little support here. Sorry, but I don't track all the DNN issues found, there are many hundreds logged.

I'm sorry you had to struggle, and I'm glad you found the resolution. It became apparent you had a problem which was not an issue of the Feedback module, so sorry I could not help with your problem.

Regards
Roger